Page tree

This article refers to the Internet browser requirements to ensure MyPlace is stable and operational.

Recommended browsers to use

There are 4 browsers in which to use MyPlace:

As a matter of preference Firefox or Google Chrome would provide optimal performance of MyPlace.

Updating your browser

Please ensure that your browser is updated with the latest version. To find out which version you are using Select 'Help' from the Menu options within the browser then click 'About'.

Known issues with Internet Explorer

On Internet Explorer (particularly version 6, 7 and 8) - there has been a few issues identified and it is advised that you upgrade to the latest version of the browser, and Turnitin no longer supports version 8.


For the official Moodle browser support details for Moodle 3.0 see Moodle Browser Requirements